Support Line Temporarily Down
Incident Report for Blackboard Inc.
Resolved
This issue has been resolved.
Posted Apr 13, 2021 - 22:12 EDT
Investigating
We are currently experiencing intermittent issues with our support line that is causing calls not to go through to our support team. We are working to resolve this as quickly as possible.
Posted Apr 13, 2021 - 21:13 EDT
This incident affected: Americas (BB Comms HQ (Formerly ParentLink)).