Mass Notifications: Sites loading slowly for a subset of clients
Incident Report for Blackboard Inc.
Resolved
This issue was resolved, and the mass notification sites are loading properly.
Posted Mar 15, 2023 - 16:03 EDT
Identified
Our development team has identified an issue causing mass notification sites to load slowly or time out for a subset of clients. We are working to resolve this as quickly as possible. If you need to get a high priority message out, please reach out to our support team for assistance.
Posted Mar 15, 2023 - 15:11 EDT