Most upgrades are now complete. We are continuing to work through those that did not succeed.
Posted Aug 12, 2026 - 17:52 EDT
Update
The issue has been resolved and the deployment to Test and Stage sites has resumed.
Posted Aug 12, 2026 - 09:55 EDT
Update
The Test and Stage releases are still paused while we continue to investigate an issue with the deployment. Updates will be provided as they become available.
The Stage and Test releases for a subset of clients has been temporarily delayed due to an issue discovered in the deployment stack. We are working to resolve the issue and will share an update when the upgrade begins.
Posted Aug 11, 2026 - 12:41 EDT
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Aug 11, 2026 - 04:00 EDT
Scheduled
Blackboard will be deploying the Blackboard SaaS 4001.0.0 Feature Release to Test and Staging environments.
Scheduled for August 11, 2026
Posted Aug 09, 2026 - 09:38 EDT
This scheduled maintenance affected: Africa (Blackboard - SaaS (Africa)), Americas (Blackboard - SaaS (US), Blackboard – SaaS Gov Cloud (US)), Europe & Middle East (Blackboard - SaaS (Saudi), Blackboard - SaaS (Europe)), and Asia Pacific (Blackboard - SaaS (Asia Pacific)).