Mass Notifications: A subset of clients having Email delivery delayed
Incident Report for Blackboard Inc.
Resolved
Emails are now being delivered as expected without delay.

To facilitate this, the "Open Rate" feature has been disabled; the team is investigating the best path forward for this feature. Until this next step is taken, a value of "0" will appear in the Open Rate field for any messages sent after February 10, 2023 on the Message Tracking>Progress tab. We apologize for any confusion this may cause.
Posted Feb 12, 2023 - 15:09 EST
Identified
Our development team has identified an issue where a portion of emails may take longer to deliver than would be expected. We are working to identify the cause and resolve the issue.
Posted Feb 10, 2023 - 17:27 EST