Blackboard LTI Services down- Global

Incident Report for Blackboard Inc.

Resolved

This incident has been resolved.
Posted Sep 10, 2025 - 13:07 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Sep 10, 2025 - 11:21 EDT

Identified

The cause of the issue has been identified. Teams are working to implement a fix.
Posted Sep 10, 2025 - 10:52 EDT

Investigating

We are currently experiencing an issue impacting BB LTI services. Our engineering teams are actively investigating the cause and working to restore services to full functionality as quickly as possible.
Posted Sep 10, 2025 - 10:18 EDT
This incident affected: Global (Blackboard - SaaS - Global).