Site down for a subset of clients.
Incident Report for Blackboard Inc.
Resolved
Our development team has resolved the issue. All services are up and running.
Posted Nov 15, 2021 - 23:30 EST
Investigating
Our development team has discovered an issue that is causing a subset of clients to have trouble pulling up the mass notification site. We are working to resolve this issue and restore services as quickly as possible.

If you need to send out an emergency message, please call our support team and they will assist you.
Posted Nov 15, 2021 - 16:49 EST
This incident affected: Americas (BB Comms HQ (Formerly ParentLink)).